Android App Bundle ve Target API Level Yeni Gereksinimleri Yayınlandı

Android, uygulamaların artık target API Level 30 (Android 11) desteklemesi gerektiğini; yeni uygulamaların güncellenmesi için son tarihin Ağustos 2021, mevcut uygulamalar için ise bu sürenin Kasım 2021 olarak belirlendiğini belirtti.


Görsel Referansı



Yeni Uygulamalar için Gereksinimler


Ağustos 2021 tarihinden itibaren uygulamaların aşağıdaki gereksinimleri karşılaması gerekiyor:

  • Uygulamalar Android App Bundle formatında olmalıdır.

  • İndirme boyutu 150MB ve üstü uygulamalar Play Asset Delivery veya Play Feature Delivery kullanmalıdır (OBB dosyaları artık desteklenmiyor).

  • Target API Level 30 veya üzeri olmalıdır.



Mevcut Uygulamalar için Gereksinimler


Kasım 2021 tarihinden itibaren mevcut uygulamaların güncellemelerinin yayınlanabilmesi için Target API Level 30 ve üstü olması bekleniyor. Güncelleme almayan uygulamalar ise Google Play üzerinden hala erişilebilir olacak.



Instant Uygulamalar için Gereksinimler


Ağustos 2021 tarihinden itibaren ZIP formatını kullanan Instant uygulamalar için instant-enabled app bundle kullanmak zorunlu olacak.


Aşağıdaki tablodan tüm gereksinimlere göz atabilirsiniz:


Ayrıntılar için: https://android-developers.googleblog.com/2020/11/new-android-app-bundle-and-target-api.html


Tüm hatırlatmalar için: https://www.mobiler.dev/hatirlatmalar


#android #playstore #targetsdk #targetapilevel

0 yorum

Son Paylaşımlar

Hepsini Gör